星愿浏览器论坛(Twinkstar Browser BBS)

关于浏览网页Flash内容出现“该版本过旧,不支持运行”问题

查看: 4147|回复: 0

2

主题

8

帖子

8

积分

初一

Rank: 1

积分
8

发表于 2022-12-22 17:26:39

本帖最后由 bwwssqjwlf 于 2022-12-22 17:32 编辑

近期注意到部分星愿浏览器的用户在浏览网页中的 Flash 内容过程中遇到了“该版本过旧,不支持运行,请升级后使用”的问题。

此问题早在今年 5 月份和 6 月份就已经提出了相当详细的解决方法。由于这里发现仍然有人反映该问题,故在此社区再重复一遍(之前已在某乎重复过,不是语病)。

另外,星愿浏览器在 8.0.1000.2204 版本已经更新内核到 98,已经原生不支持 Flash Player。若需使用 Flash Player,请务必使用不高于 7.12.1000.2112 的版本。

方法一:修改HOSTS

来源:【小花仙】关于微端和浏览器提示“该版本过旧,不支持运行”问题

关闭浏览器。

将电脑上所有的“Shockwave Flash”目录删除。注意删除前确保各目录下没有重要文件。建议使用 Everything 软件操作

在资源管理器找到 C:\Windows\System32\drivers\etc\hosts 文件,右键属性,去掉只读选项,然后切换到安全选项卡,高级,把所有者改成Administrators,点击应用,然后重新加载权限窗口,然后点添加,选择主体Administrators,然后选中完全控制。然后一直确定。

右键开始按钮,选择“Windows Powershell (管理员)”或者“Windows 终端 (管理员)”,输入

  1. notepad C:\Windows\System32\drivers\etc\hosts
复制代码


回车,然后添加下列内容到新的行:

  1. 127.0.0.1 geo2.adobe.com
  2. 127.0.0.1 fpdownload2.macromedia.com
  3. 127.0.0.1 fpdownload.macromedia.com
  4. 127.0.0.1 macromedia.com
复制代码


这时候再打开浏览器,访问带有 Flash 内容的网页,应该可以恢复访问了。

方法二:替换为版本 26.0.0.151 的 Flash Player

来源:【22.6.25更新】需要用Flash Player又不想安装重橙版?官方原版插件就可以~

Flash Player 最后一个没有加“该版本过旧,不支持运行”检测的版本是 27.0.0.131,但是这个版本在 NPAPI 和 ActiveX 版本都出现了不同程度的故障,这里浏览器使用的 PPAPI 版本虽然未接到出现故障,但是也很难找到可以下载的地方。所以更建议使用 26.0.0.151 的版本,这个版本也是有 64 位版本的。

首先卸载所有已经安装的 Flash Player,然后在国产浏览器安装目录的 User Data 目录下新建文件夹 PepperFlash,然后把下载得到的 Flash Player 26.0.0.151 压缩包里面的“pepflashplayer”和“manifest.json”两个文件拷过来,即可继续使用 Flash。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

bwwssqjwlf

发新帖

热门帖子

关注我

小黑屋| 

©Powered by 北京天之歌者科技有限公司星愿浏览器 ( 京ICP备16039518号 )  

GMT+8, 2024-6-17 22:08 , Processed in 0.048980 second(s), 27 queries .

快速回复 返回顶部 返回列表